faqts : Computers : Programming : Languages : PHP : General Information : PHP4 to PHP5 Migration

+ Search
Add Entry AlertManage Folder Edit Entry Add page to http://del.icio.us/
Did You Find This Entry Useful?

0 of 1 people (0%) answered Yes
Recently 0 of 1 people (0%) answered Yes

Entry

We+are+using+PHP+Version+4.1.2%3B+and+need+to+upgrade+so+we+can+use+FREETYPE+2.

Mar 17th, 2007 14:07
Scott M,


We are currently using:
* PHP Version 4.1.2 and need to upgrade to PHP v5.x, for:
1) Freetype 2
2) GD ( currently 2.0 or higher )
Our current configuration is:
* SERVER_SOFTWARE Apache/1.3.26 (Unix) 
* AuthMySQL/2.20 
* PHP/4.1.2 
Configured with: '--with-jpeg-dir=/usr/lib' '--with-jpeg' '--with-png-
dir=/usr/lib' '--with-png' '--with-zlib' '--with-freetype-
dir=/usr/lib' '--with-freetype' '--with-gd' ( and other settings ).... 
* mod_gzip/1.3.19.1a 
* mod_ssl/2.8.9 
* OpenSSL/0.9.6g 
> we are on a shared & hosted system belonging to a hosting service 
that we "rent" on a monthly basis.
So, the $1 million $$$ question is....  can this be done:
* under the current server software?
-OR-
* requiring an upgrade of the server software that can be done simply 
with FEW holes & fallout?
Please let us know.
-Scott M